Initialization Error 1 on Manually Mapped Module

Issues related to VMProtect
springtime
Posts: 3
Joined: Sat May 14, 2022 3:46 pm

Initialization Error 1 on Manually Mapped Module

Postby springtime » Sun Dec 04, 2022 7:34 am

Hello there,

I have an active VMProtect Ultimate license.
I am trying to load my module protected with VMProtect using my manual mapper library. When the module loads, VMProtect produces "Initialization Error 1". This does not happen to non-protected modules. This happens on any module protected by VMProtect, even a dummy DLL. I have played around with the Memory Protection, Import Protection, Resource Protection, Packing, and Debugger settings. Changing any of these settings does not change the outcome. No matter what, initialization error 1 is prompted.

I have also attempted to preserve all PE headers instead of erasing them, this does not change anything.

I am testing this on my local machine and can reproduce it easily.

Admin
Site Admin
Posts: 2342
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: Initialization Error 1 on Manually Mapped Module

Postby Admin » Sun Dec 04, 2022 7:45 am

"Initialization error 1" means that VirtualProtect has returned an error while working the vmprotect loader.

springtime
Posts: 3
Joined: Sat May 14, 2022 3:46 pm

Re: Initialization Error 1 on Manually Mapped Module

Postby springtime » Sun Dec 04, 2022 7:52 am

Is there anymore information you can provide so I can attempt to prevent this from happening?

To be clear, I use VirtualProtect in my own code in the module being loaded and it works fine without error.