Не работает строка деактивации

Issues related to WebLM
andvl
Posts: 10
Joined: Thu Jan 16, 2020 11:07 am

Не работает строка деактивации

Postby andvl » Fri Apr 23, 2021 7:38 am

1) На вашем http://weblm.vmpsoft.com я сделал продукт Мой1 по выдаче кодов активации.
2) Сделал мод продукта Мой1 бессрочный по выдаче бессрочных кодов активации.
3) Сделал новый код активации, вот он: HJRN-ZC45-BL7M
3) Из продукта Мой1 экспортировал себе на компьютер файл wmp
4) Импортировал его в свой проект и сделал пробную программу для онлайн и оффлайн активации
5) Онлайн активация и деактивация проходят без нареканий - в http://weblm.vmpsoft.com всё отображается происходящее
6) Проблема с офлайн
7) Образую текст функцией VMProtectGetOfflineActivationString()
8) Перехожу http://weblm.vmpsoft.com/offline.php и ввожу текст в поле: "Введите строку активации / деактивации: " Нажимаю отправить- получаю серийный номер, устанавливаю его в программе - всё работает. Спасибо. В http://weblm.vmpsoft.com активация отображается.
9) Теперь пытаюсь деактивировать оффлайн.
10) Образую текст функцией VMProtectGetOfflineDeactivationString()
11) Перехожу http://weblm.vmpsoft.com/offline.php и ввожу текст в поле: "Введите строку активации / деактивации: " Нажимаю отправить- получаю сообщение: Неверный серийный номер. В http://weblm.vmpsoft.com деактивация НЕ отображается. Пробую ввести в то поле тот самый серийный номер, выдаёт: Неверная строка активации.
В чём дело? Что происходит? Как оффлайн деактивировать код активации?

Admin
Site Admin
Posts: 2030
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: Не работает строка деактивации

Postby Admin » Tue Apr 27, 2021 6:46 am

Значит вы что-то неправильно делаете. Обратите внимание, что первый параметр для VMProtectGetOfflineDeactivationString - это серийный номер, а не код активации.

andvl
Posts: 10
Joined: Thu Jan 16, 2020 11:07 am

Re: Не работает строка деактивации

Postby andvl » Tue Apr 27, 2021 7:08 pm

Огромное спасибо. Я именно код активации подставлял. Да, все работает.

Помогите, пожалуйста, разобраться в другом вопросе.
В 2018 я приобрел у вас WebLM v2.4.4.22 установил его на пробный сайт. Все нормально. Никаких ошибок при установке.
Теперь на днях приобрел через подписку WebLM v2.4.6.23
При установке выдает следующие ошибки:
$math_wrappers
Warning: Cannot modify header information - headers already sent by (output started at /var/www/u0920581/data/www/mudrosoft.com/weblm/include/lang.inc.php:1) in /var/www/u0920581/data/www/mudrosoft.com/weblm/include/lang.inc.php on line 34
и потом другие, тоже начинающиеся с $math_wrappers
В чем тут дело? Может надо поменять какие-то настройки сайта?
Но почему тогда предыдущая версия нормально устанавливается?

Admin
Site Admin
Posts: 2030
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: Не работает строка деактивации

Postby Admin » Thu Apr 29, 2021 8:03 am

Первый раз видим такую проблему. Пока идей нет.

andvl
Posts: 10
Joined: Thu Jan 16, 2020 11:07 am

Re: Не работает строка деактивации

Postby andvl » Thu Apr 29, 2021 10:07 pm

Спасибо, все заработало. Ребята из техподдержки хостинга помогли.