libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Issues related to VMProtect
supermilg
Posts: 7
Joined: Sat Oct 21, 2017 3:46 pm

libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby supermilg » Sat Mar 03, 2018 10:17 am

We link libVMProtectSDK64.so to our program in cent os 6.6 , however, linker says:
/libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'
collect2: error: ld returned 1 exit status

Can you sovle this problem?

supermilg
Posts: 7
Joined: Sat Oct 21, 2017 3:46 pm

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby supermilg » Sat Mar 03, 2018 10:19 am

In centos 6.6 we use the gcc and g++ from devtoolset-4 . gcc version 5.3.1 20160406 (Red Hat 5.3.1-6) (GCC)

Admin
Site Admin
Posts: 1411
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby Admin » Sat Mar 03, 2018 2:49 pm

We recommend to install Centos 7 or later.

supermilg
Posts: 7
Joined: Sat Oct 21, 2017 3:46 pm

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby supermilg » Wed Mar 07, 2018 4:40 am

Hi , My custormer's machine only run on Centos 6.6 in their production env, my software( protected by vmprotect) have to support on that OS version. Need help!!

Admin
Site Admin
Posts: 1411
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby Admin » Wed Mar 07, 2018 6:24 am

Hi , My custormer's machine only run on Centos 6.6 in their production env, my software( protected by vmprotect)

How your application does require libVMProtectSDK64 after protection with VMProtect?

supermilg
Posts: 7
Joined: Sat Oct 21, 2017 3:46 pm

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby supermilg » Thu Mar 08, 2018 4:04 am

I need to compile and link my program in Centos 6. I use vmprotect api to protect many pieces of codes in my program, so I have to link libVMProtectSDK64.so to my program, and after that, I just can use vmprotect to pack and protect it, right?! My problem happend during link, not after packing by vmprotect.

If I don't use any api of vmprotect, I just compile an link a nake program which can run in centos 6, then , I used vmprotect gui (runs in centos 7) to pack my program to an myprogram_vmp, I copy myprogram_vmp to cent os 6, it still can't not run in centos 6( the problem is still about glibc version.)

You can try and if you can successfuly run an vmprotect program in cent os 6, you can tell me how to do it ?

Ps. vmprotect is a prefect tools, but you really need to solve that problem, and many production envirment is still running on the Centos 6

supermilg
Posts: 7
Joined: Sat Oct 21, 2017 3:46 pm

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby supermilg » Sat Mar 10, 2018 9:02 am

Is there any way?

Admin
Site Admin
Posts: 1411
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby Admin » Mon Mar 12, 2018 8:29 am

Please try the latest build (944).

supermilg
Posts: 7
Joined: Sat Oct 21, 2017 3:46 pm

Re: libVMProtectSDK64.so: undefined reference to `memcpy@GLIBC_2.14'

Postby supermilg » Mon Mar 12, 2018 9:58 am

Thank you! VMProtect is really professional !


Return to “Technical questions”

Who is online

Users browsing this forum: No registered users and 2 guests