VMProtect: problem after activation / проблема после активации

Issues related to VMProtect
Penguin
Posts: 2
Joined: Tue May 02, 2017 11:33 am
Location: Russia, Kaliningrad

VMProtect: problem after activation / проблема после активации

Postby Penguin » Tue May 02, 2017 3:32 pm

Доброго дня

Что имеем: рабочий билд продукта обёрнутый в VMP.

При первом запуске продукта необходимо активировать его (Web License Manager). Весь процесс происходит успешно, нареканий никаких. Также адекватно обрабатываются ошибки (опечатка, отсутствие связи, завернуть в VMP забыли и др.). После активации продукт работает по назначению стабильно.
Проблема появляется при втором и последующем запусках т.е. уже активированного продукта. Запущенная программа через некоторый тайм-аут (видимо зависит от мощности машины) "падает". Момент падения не отлавливается, происходит где-то мимо. Если деактивировать и снова запустить и активировать, то стабильная работа.

Билд рабочий, сам по себе подобных проблем не имеет. Обернутый в VMP билд демо-версии работает так же без нареканий, так же имеется система старой активации, она тоже не конфликтует с окружением.

В чём может быть проблема? Пробовали шаманить с настройками VMP при оборачивании, эффекта не возымело.

Admin
Site Admin
Posts: 1305
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: VMProtect: problem after activation / проблема после активации

Postby Admin » Wed May 03, 2017 5:31 pm

Можете прислать тестовый пример (оригинал EXE+MAP+VMP файлы), на котором воспроизводится проблема?

Penguin
Posts: 2
Joined: Tue May 02, 2017 11:33 am
Location: Russia, Kaliningrad

Re: VMProtect: problem after activation / проблема после активации

Postby Penguin » Thu May 04, 2017 10:44 am

Admin wrote:Можете прислать тестовый пример (оригинал EXE+MAP+VMP файлы), на котором воспроизводится проблема?

Да, могу
Напишите куда отправить

Admin
Site Admin
Posts: 1305
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: VMProtect: problem after activation / проблема после активации

Postby Admin » Thu May 04, 2017 10:45 am



Return to “Technical questions”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest