VMP with libcurl4 support

Issues related to VMProtect
jumper1
Posts: 1
Joined: Tue Sep 01, 2020 4:37 pm

VMP with libcurl4 support

Postby jumper1 » Tue Sep 01, 2020 4:44 pm

We bought a license for VMProtect Ultimate a couple of months back. However, we are having a problem with it being dependant on libcurl3. Our developer says all the current build of Ubuntu and Amazon Linux supports libcurl4 only and also our binary is also dependant on it but VMProtect itself requires libcurl3. While a hack is available in Ubuntu to install libcur34 together, there is nothing similar for Amazon Linux v2. Can you change the dependency of VMProtect from libcurl3 to libcurl4 since it's the latest version anyway and build a new version? Or is there another version for libcurl4?

I emailed support with this question 5 days back but I am yet to receive a response.

Admin
Site Admin
Posts: 2008
Joined: Mon Aug 21, 2006 8:19 pm
Location: Russia, E-burg
Contact:

Re: VMP with libcurl4 support

Postby Admin » Thu Sep 03, 2020 7:20 am

Please notice that VMProtect uses curl 7.35, so I don't understand what "libcurl3" do you mean. Could you provide us more detailed information?