Search found 9 matches

by flowercodec
Sun Nov 17, 2019 12:50 pm
Forum: Purchasing or Upgrading
Topic: I have purchase the new subscription
Replies: 1
Views: 1463

I have purchase the new subscription

I have purchase the new subscription at 2019/11/12, The PayPro order number is 18219078.
but in the about window, it still shows that free updates period is "2019/9/20" and need to purchase a subscription.
What's wrong...
about.png
about.png (25.96 KiB) Viewed 1463 times
by flowercodec
Sat Dec 15, 2018 9:55 am
Forum: Technical questions
Topic: error after protect .so file under centos 6.8
Replies: 3
Views: 1081

Re: error after protect .so file under centos 6.8

Admin wrote:Please try the 1060 build.

the 1060 build works fine.
Thanks!
by flowercodec
Fri Dec 14, 2018 11:55 am
Forum: Technical questions
Topic: error after protect .so file under centos 6.8
Replies: 3
Views: 1081

Re: error after protect .so file under centos 6.8

I try the 976 build, works fine.
by flowercodec
Thu Dec 13, 2018 2:04 pm
Forum: Technical questions
Topic: error after protect .so file under centos 6.8
Replies: 3
Views: 1081

error after protect .so file under centos 6.8

it shows: /lib64/libc.so.6: version `GLIBC_2.17' not found ldd -r -d my.so ./my.so: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by ./my.so) linux-vdso.so.1 => (0x00007ffe5adff000) libpthread.so.0 => /lib64/libpthread.so.0 (0x00007ff48a25c000) libdl.so.2 => /lib64/libdl.so.2 (0x00007ff...
by flowercodec
Sat Nov 10, 2018 7:42 am
Forum: Technical questions
Topic: cant's dlopen after protect dylib under macOS 10.13
Replies: 8
Views: 2366

Re: cant's dlopen after protect dylib under macOS 10.13

Admin wrote:Please try the 1028 build.


1028 build works fine.
I also test it under macOS 10.14.1, works fine too!
Thanks.

Is 1028 build is a stable version? So I can use it for my release application.
by flowercodec
Thu Sep 06, 2018 3:47 am
Forum: Technical questions
Topic: cant's dlopen after protect dylib under macOS 10.13
Replies: 8
Views: 2366

Re: cant's dlopen after protect dylib under macOS 10.13

Admin wrote:Please try the 1013 build.

I want to send the binary to you, is it sent to info@vmpsoft.com ?
by flowercodec
Wed Sep 05, 2018 1:21 am
Forum: Technical questions
Topic: cant's dlopen after protect dylib under macOS 10.13
Replies: 8
Views: 2366

Re: cant's dlopen after protect dylib under macOS 10.13

Please try the 1013 build. Hi Admin, I instal 1013 build version. it seem to be another problem. dlopen error message: REBASE_OPCODE_DO_REBASE_ADD_ADDR_ULEB pointer rebase is in executable segment I search dylib source code again, found the error code. at dyld-519.2.2\dyld3\MachOParser.cpp:2612, fu...
by flowercodec
Tue Aug 21, 2018 3:29 am
Forum: Technical questions
Topic: cant's dlopen after protect dylib under macOS 10.13
Replies: 8
Views: 2366

Re: cant's dlopen after protect dylib under macOS 10.13

Hi Admin, after protect dylib, I find sectname __mod_init_func, segname __TEXT1.(not found before protect) I think this should be the reason why dlopen gave an error. Is it possible to manually call some initialization through the VMP SDK (a new feature). Then we can bypass "the new crap"....
by flowercodec
Fri Aug 17, 2018 10:19 am
Forum: Technical questions
Topic: cant's dlopen after protect dylib under macOS 10.13
Replies: 8
Views: 2366

cant's dlopen after protect dylib under macOS 10.13

Hi, dlopen error message: initializer 0x768FAB does not point within __TEXT segment It works fine under macOS 10.12 and before, How to fix this problem. Thanks. Apple's dylib loading process is open source dyld-519.2.2(macOS 10.13 using this version) download url: https://opensource.apple.com/tarbal...